Exchange 2013/2016 Cumulative Updates and Hybrid Environment.

Exchange 2016 CU2 and Exchange 2013 CU13 now supports .NET Framework 4.6.1

Today Microsoft Exchange Team made announcement of not one but two cumulative updates, one for Exchange 2013 which is Cumulative update 13 and Cumulative CU2 for Exchange 2016.  With these CU updates .NET 4.6.1 is officially supported now.

I’d like to start with Hybrid Deployment first

Minimum CU For Hybrid environments

So if you are and Exchange 2013 or Exchange 2016 or mix of both then you have no choice EXCEPT  upgrade to either CU12 minimum (.NET 4.6.1 is not supported on CU12) or CU1 at minimum (.NET 4.6.1 is not supported on CU1) respectively. So if you on hybrid and want to be at the upgrade to  .NET 4.6.1 then you have to be on the latest CU Levels.

How to proceed?

Do not install .NET 4.6.1 directly on your existing CU, first you need to upgrade to CU13 for Exchange 2013 and CU2 for Exchange 2016, this is the recommendation as per #msexchange team.

  • Exchange Server 2016 Cumulative Update 2 does include updates to Active Directory Schema

Post CU installation

(these three KB article solves the same issue of course you need separate hot fix for all the OS)

Migration to Modern Public Folder Resolved

The issue reported in KB3161916 has been resolved.

To prevent any installation issue
make sure that Windows PowerShell Script Execution Policy is set to “Unrestricted” on the server being upgraded to.

SHA-2 Support for Self-Signed Certificates

The New-ExchangeCertificate cmdlet has been updated to produce a SHA-2 certificate for all self-signed certificates created by Exchange. Customers may opt to replace existing non-SHA2 certificates generated by previous releases as they see fit.

Support for Exchange 2010 ???

Exchange 2010 is still not support and will never be as per Jeff Guillet – http://www.expta.com/2016/06/exchange-2016-cu2-and-exchange-2013.html (read his own comment at the bottom of this post)

For full details checkout #msExchange Team Blog